Thanks for ideas, Malcolm.
I am slightly against "create_db_table", cause the name implies that
it controls "creating DB tables", while in fact it controls ANY
operations on DB tables - CREATE/ALTER/DROP TABLE, CREATE/DROP INDEX,
etc. But I fully agree that my name is not better and I am open for
suggestions. Maybe... "manage_db_table", and the explanation in the
documents like "this Meta option whether the table can be managed when
using manage.py commands"?
Also I'll see if I can add any tests using call_command() function,
this could probably work (according to some other testcases).

On 13 дек, 02:10, Malcolm Tredinnick <[EMAIL PROTECTED]> wrote:
> On Wed, 2007-12-12 at 05:29 -0800, Alex Myodov wrote:
> > Hi all.
>
> > Can someone experienced please have a look at the #3163 ticket
> > ("sql_generation_required" Meta option) and hint me what other steps
> > should I do to move the patch forward?
>
> The name is silly. Call it create_db_table and have it default to True.
> For the (very few) users who need this functionality, they can set it to
> False and it won't generate any SQL for that model. That's all that's
> needed here.
>
> Tests will be very painful and I wouldn't worry about it too much, since
> it's such an edge case and will just add overhead. If you run
> "./manage.py sql <model_name>" and see any output, it doesn't work.
> That's really all that's required there.
>
> Keep in mind, though, that at that point, might still take a bit of time
> to get final review and then be committed. There are hundreds of open
> tickets in the system, many of much greater impact on the user base than
> this one. We're working towards getting a 1.0 release out the door and
> need to focus a lot of energy on the features that impact 100% of the
> userbase at the temporary expense of those that impact 1%. That's the
> way life works. So get the patch up to as good as it can get and people
> who really, really need the feature can apply hte patch themselves and
> we'll get it into the tree at some point when we have a moment.
>
> Regards,
> Malcolm
>
> --
> Remember that you are unique. Just like everyone 
> else.http://www.pointy-stick.com/blog/
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Django developers" group.
To post to this group, send email to django-developers@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/django-developers?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to