Archit, On 06/21/2016 09:46 PM, Archit Taneja wrote: > > > On 6/14/2016 5:15 PM, Yakir Yang wrote: >> RK3399 and RK3288 shared the same eDP IP controller, only some light >> difference with VOP configure and GRF configure. >> >> Also same misc fix to analogix_dp driver: >> - Hotplug invalid which report by Dan Carpenter >> - Make panel detect to an optional action >> - correct the register bit define error in ANALOGIX_DP_PLL_REG_1 >> >> >> Changes in v3: >> - Correct the misspell of "marcos" in commit message (Dominik, >> reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346312/9//COMMIT_MSG at 9] >> - Add reviewed flag from Stéphane. >> [https://chromium-review.googlesource.com/#/c/346312/16] >> - Add tested flag from Javier. >> - Write a kerneldoc-style comment explaining the chips data fields >> (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346313/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c >> at 39] >> - Drop the '.lcdcsel_mask' number in chips data field (Tomasz, >> reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346313/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c >> at 382] >> - Add acked flag from Mark. >> - Add reviewed flag from Tomasz. >> [https://chromium-review.googlesource.com/#/c/346315/15] >> - Add tested flag from Javier >> - Make this hack code more clear (Tomasz, reviewed at Google Gerrit) >> reg = ~reg & REF_CLK_MASK; ---> reg ^= REF_CLK_MASK; >> [https://chromium-review.googlesource.com/#/c/346852/7/drivers/gpu/drm/bridge/analogix/analogix_dp_reg.c >> at 80] >> - Add tested flag from Javier >> - Give the "rk3399-edp" a separate line for clarity in document >> (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346314/10/Documentation/devicetree/bindings/display/rockchip/analogix_dp-rockchip.txt >> at 5] >> - Move 'output_type' setting before the return statement (Tomasz, >> reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346314/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c >> at 154] >> - Add the acked flag from Mark. >> - Add the acked flag from Mark. >> - Avoid to change any internal driver state in .mode_valid interface. >> (Tomasz, reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346318/10/drivers/gpu/drm/rockchip/analogix_dp-rockchip.c >> at 113] >> - Hook the connector's color_formats in .get_modes directly. (Tomasz, >> reviewed at Google Gerrit) >> [https://chromium-review.googlesource.com/#/c/346317/15] >> - Add the acked flag from Mark. >> - Add the reviewed flag from Tomasz. >> [https://chromium-review.googlesource.com/#/c/346853/12] >> - Add the acked flag from Mark. >> - Add reviewed flag from Stéphane. >> [https://chromium-review.googlesource.com/#/c/346319/15] >> - Add tested flag from Javier >> >> Changes in v2: >> - new patch in v2 >> - rebase with drm-next, fix some conflicts >> - new patch in v2 >> >> Yakir Yang (10): >> drm/bridge: analogix_dp: rename RK3288_DP to ROCKCHIP_DP >> drm/rockchip: analogix_dp: split the lcdc select setting into device >> data >> drm/bridge: analogix_dp: correct the register bit define error in >> ANALOGIX_DP_PLL_REG_1 >> drm/bridge: analogix_dp: some rockchip chips need to flip REF_CLK bit >> setting >> drm/rockchip: analogix_dp: add rk3399 eDP support >> drm/rockchip: analogix_dp: make panel detect to an optional action >> drm/bridge: analogix_dp: passing the connector as an argument in >> .get_modes() >> drm/rockchip: analogix_dp: correct the connector display color format >> and bpc >> drm/rockchip: analogix_dp: update the comments about why need to >> hardcode VOP output mode >> drm/bridge: analogix_dp: fix no drm hpd event when panel plug in > > Is the plan to take all the bridge+rockchip stuff via the rockchip pull > request? >
Yep, most of those patch need to rely on others, so it's better to collect all of them into one pull request ;) Thanks, - Yakir > Thanks, > Archit > >> >> .../bindings/display/bridge/analogix_dp.txt | 1 + >> .../display/rockchip/analogix_dp-rockchip.txt | 3 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_core.c | 6 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_core.h | 8 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_reg.c | 12 +- >> drivers/gpu/drm/bridge/analogix/analogix_dp_reg.h | 5 +- >> drivers/gpu/drm/exynos/exynos_dp.c | 4 +- >> drivers/gpu/drm/rockchip/analogix_dp-rockchip.c | 158 >> ++++++++++++++------- >> include/drm/bridge/analogix_dp.h | 9 +- >> 9 files changed, 141 insertions(+), 65 deletions(-) >> >