Hi Oleksandr & Stafan. Thanks for the update to panel-lvds.
On Wed, Jan 15, 2020 at 12:34:17PM +0000, Oleksandr Suvorov wrote: > From: Stefan Agner <ste...@agner.ch> > > The LVDS panel driver has almost everything which is required to > describe a simple parallel RGB panel (also known as DPI, Display > Pixel Interface). > > Signed-off-by: Stefan Agner <ste...@agner.ch> > Signed-off-by: Oleksandr Suvorov <oleksandr.suvo...@toradex.com> > --- There are a few high-level things we need to have sorted out. The driver, when this patch is added, assumes that certain properties are now mandatory when using the panel-dpi compatible. - data-mapping - width-mm - height-mm - panel-timing But this does not match the panel-dpi binding. So we need the panel-dpi binding updated first. The current driver specify the connector type in drm_panel_init(). But a DPI panel is assumed to use a DRM_MODE_CONNECTOR_DPI, and not a DRM_MODE_CONNECTOR_LVDS. So the drm_panel_init() call needs to take into account the type of binding. > @@ -257,7 +279,7 @@ static struct platform_driver panel_lvds_driver = { > .probe = panel_lvds_probe, > .remove = panel_lvds_remove, > .driver = { > - .name = "panel-lvds", > + .name = "panel-generic", I think changing the name of the driver like this is an UAPI change, which is not OK > .of_match_table = panel_lvds_of_table, > }, > }; Sam _______________________________________________ dri-devel mailing list dri-devel@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/dri-devel