On Thu, 05 Mar 2020, Manasi Navare <manasi.d.nav...@intel.com> wrote: > This patch adds defines for the detailed monitor > range flags as per the EDID specification. > > Suggested-by: Ville Syrjälä <ville.syrj...@linux.intel.com> > Cc: Ville Syrjälä <ville.syrj...@linux.intel.com> > Cc: Harry Wentland <harry.wentl...@amd.com> > Cc: Clinton A Taylor <clinton.a.tay...@intel.com> > Cc: Kazlauskas Nicholas <nicholas.kazlaus...@amd.com> > Signed-off-by: Manasi Navare <manasi.d.nav...@intel.com> > --- > include/drm/drm_edid.h | 5 +++++ > 1 file changed, 5 insertions(+) > > diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h > index f0b03d401c27..f89c97623845 100644 > --- a/include/drm/drm_edid.h > +++ b/include/drm/drm_edid.h > @@ -91,6 +91,11 @@ struct detailed_data_string { > u8 str[13]; > } __attribute__((packed)); > > +#define EDID_DEFAULT_GTF_SUPPORT_FLAG 0x00 > +#define EDID_RANGE_LIMITS_ONLY_FLAG 0x01 > +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02 > +#define EDID_CVT_SUPPORT_FLAG 0x04
Bikeshed for consideration: drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_ prefix, and then some with no prefix at all really. Should we start consolidating on something when we add more? BR, Jani. > + > struct detailed_data_monitor_range { > u8 min_vfreq; > u8 max_vfreq; -- Jani Nikula, Intel Open Source Graphics Center _______________________________________________ dri-devel mailing list dri-devel@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/dri-devel