On Tue, Jul 14, 2020 at 02:41:37PM +0900, Benjamin Poirier wrote:
> On 2020-07-13 17:50 +0530, Suraj Upadhyay wrote:
> > Simplify while loops into more readable and simple for loops.
> > 
> > Signed-off-by: Suraj Upadhyay <usura...@gmail.com>
> > ---
> [...]
> > @@ -1824,7 +1821,7 @@ static struct sk_buff *ql_build_rx_skb(struct 
> > ql_adapter *qdev,
> >                     sbq_desc->p.skb = NULL;
> >                     skb_reserve(skb, NET_IP_ALIGN);
> >             }
> > -           do {
> > +           for (; length > 0; length -= size, i++) {
> >                     lbq_desc = ql_get_curr_lchunk(qdev, rx_ring);
> >                     size = min(length, qdev->lbq_buf_size);
> >  
> > @@ -1839,7 +1836,7 @@ static struct sk_buff *ql_build_rx_skb(struct 
> > ql_adapter *qdev,
> >                     skb->truesize += size;
> >                     length -= size;
> >                     i++;
> > -           } while (length > 0);
> > +           }
> 
> Looks like length and i modification should be removed from here. But in
> this instance, maybe the original was better anyways.
 
Thanks for pointing that out. It nearly slipped.

> Agreed with Dan. At least some of those loops can be converted to "count
> up" loops for a more familiar appearance.

I mostly tried to convert the do-while loops, which I think are't that
obvious than while and for loops.

Thanks,

Suraj Upadhyay.

Attachment: signature.asc
Description: PGP signature

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to