From: Yang Guang <yang.gua...@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zea...@zte.com.cn>
Signed-off-by: David Yang <davidcomponent...@gmail.com>
Signed-off-by: Yang Guang <yang.gua...@zte.com.cn>
---
 drivers/video/fbdev/sis/sis_main.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/video/fbdev/sis/sis_main.c 
b/drivers/video/fbdev/sis/sis_main.c
index 266a5582f94d..742f62986b80 100644
--- a/drivers/video/fbdev/sis/sis_main.c
+++ b/drivers/video/fbdev/sis/sis_main.c
@@ -213,7 +213,7 @@ static void sisfb_search_mode(char *name, bool quiet)
                /* This does some fuzzy mode naming detection */
                if(sscanf(strbuf1, "%u %u %u %u", &xres, &yres, &depth, &rate) 
== 4) {
                        if((rate <= 32) || (depth > 32)) {
-                               j = rate; rate = depth; depth = j;
+                               swap(rate, depth);
                        }
                        sprintf(strbuf, "%ux%ux%u", xres, yres, depth);
                        nameptr = strbuf;
-- 
2.30.2

Reply via email to