On 24/10/2022 22.11, Gwan-gyeong Mun wrote:
> From: Kees Cook <keesc...@chromium.org>
> 
> Implement a robust overflows_type() macro to test if a variable or
> constant value would overflow another variable or type. This can be
> used as a constant expression for static_assert() (which requires a
> constant expression[1][2]) when used on constant values. This must be
> constructed manually, since __builtin_add_overflow() does not produce
> a constant expression[3].
> 
> Additionally adds castable_to_type(), similar to __same_type(), but for
> checking if a constant value would overflow if cast to a given type.
> 

> +#define __overflows_type_constexpr(x, T) (                   \
> +     is_unsigned_type(typeof(x)) ?                           \
> +             (x) > type_max(typeof(T)) ? 1 : 0               \
> +     : is_unsigned_type(typeof(T)) ?                         \
> +             (x) < 0 || (x) > type_max(typeof(T)) ? 1 : 0    \
> +             : (x) < type_min(typeof(T)) ||                  \
> +               (x) > type_max(typeof(T)) ? 1 : 0)
> +

Can't all these instances of "foo ? 1 : 0" be simplified to "foo"? That
would improve the readability of this thing somewhat IMO.

Rasmus

Reply via email to