On 2023/6/22 17:21, Geert Uytterhoeven wrote:
Rename the "plane" member of the shmob_drm_plane subclass structure to
"base", to improve readability.

Signed-off-by: Geert Uytterhoeven <geert+rene...@glider.be>
Reviewed-by: Laurent Pinchart <laurent.pinchart+rene...@ideasonboard.com>

Reviewed-by: Sui Jingfeng <suijingf...@loongson.cn>

---
  drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c | 10 +++++-----
  1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c 
b/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c
index 63886015baaebfc0..e300e5c0de70a9b1 100644
--- a/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c
+++ b/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c
@@ -20,7 +20,7 @@
  #include "shmob_drm_regs.h"
struct shmob_drm_plane {
-       struct drm_plane plane;
+       struct drm_plane base;
        unsigned int index;
        unsigned int alpha;
@@ -37,7 +37,7 @@ struct shmob_drm_plane { static inline struct shmob_drm_plane *to_shmob_plane(struct drm_plane *plane)
  {
-       return container_of(plane, struct shmob_drm_plane, plane);
+       return container_of(plane, struct shmob_drm_plane, base);
  }
static void shmob_drm_plane_compute_base(struct shmob_drm_plane *splane,
@@ -64,7 +64,7 @@ static void shmob_drm_plane_compute_base(struct 
shmob_drm_plane *splane,
  static void __shmob_drm_plane_setup(struct shmob_drm_plane *splane,
                                    struct drm_framebuffer *fb)
  {
-       struct shmob_drm_device *sdev = to_shmob_device(splane->plane.dev);
+       struct shmob_drm_device *sdev = to_shmob_device(splane->base.dev);
        unsigned int ovl_idx = splane->index - 1;
        u32 format;
@@ -221,7 +221,7 @@ struct drm_plane *shmob_drm_plane_create(struct shmob_drm_device *sdev,
        }
splane = drmm_universal_plane_alloc(&sdev->ddev,
-                                           struct shmob_drm_plane, plane, 1,
+                                           struct shmob_drm_plane, base, 1,
                                            funcs, formats,
                                            ARRAY_SIZE(formats),  NULL, type,
                                            NULL);
@@ -231,5 +231,5 @@ struct drm_plane *shmob_drm_plane_create(struct 
shmob_drm_device *sdev,
        splane->index = index;
        splane->alpha = 255;
- return &splane->plane;
+       return &splane->base;
  }

--
Jingfeng

Reply via email to