Hi Tvrtko,

> --- a/drivers/gpu/drm/i915/gem/i915_gem_domain.c
> +++ b/drivers/gpu/drm/i915/gem/i915_gem_domain.c
> @@ -68,10 +68,8 @@ flush_write_domain(struct drm_i915_gem_object *obj, 
> unsigned int flush_domains)
>       switch (obj->write_domain) {
>       case I915_GEM_DOMAIN_GTT:
>               spin_lock(&obj->vma.lock);
> -             for_each_ggtt_vma(vma, obj) {
> -                     if (i915_vma_unset_ggtt_write(vma))
> -                             intel_gt_flush_ggtt_writes(vma->vm->gt);
> -             }
> +             for_each_ggtt_vma(vma, obj)
> +                     i915_vma_flush_writes(vma);

yes, that's some duplicated code removed here! Thanks! I believe
I'm in time to add my:

Reviewed-by: Andi Shyti <andi.sh...@linux.intel.com> 

Andi

>               spin_unlock(&obj->vma.lock);
>  
>               i915_gem_object_flush_frontbuffer(obj, ORIGIN_CPU);
> -- 
> 2.39.2

Reply via email to