On Thursday, 16 July 2026 at 17:22, Luca Ceresoli <[email protected]> wrote: > On Wed, 15 Jul 2026 15:10:33 +0200, Esben Haabendal <[email protected]> wrote: > > > diff --git a/drivers/gpu/drm/bridge/ti-sn65dsi83.c > > b/drivers/gpu/drm/bridge/ti-sn65dsi83.c > > index 7e73035d7798..02ae2b8179b0 100644 > > --- a/drivers/gpu/drm/bridge/ti-sn65dsi83.c > > +++ b/drivers/gpu/drm/bridge/ti-sn65dsi83.c > > @@ -893,6 +895,7 @@ static int sn65dsi83_parse_dt(struct sn65dsi83 *ctx, > > enum sn65dsi83_model model) > > { > > struct drm_bridge *panel_bridge; > > struct device *dev = ctx->dev; > > + u32 panel_port = 2; > > Thanks for having applied the changes I had suggested. > > I'm afraid I realized right now the "panel_port" name is not ideal because > there could be another bridge at the output port and not directly a > panel. Should you have a reason to send a v3 I'd rename to output_port (and > keep my R-by if that's the only change). Otherwise I can do it while > applying the patch.
What about the panel_bridge member of struct sn65dsi83? We use panel_port/output_port as argument to devm_drm_of_get_bridge() and assign the bridge we get from that to ctx->panel_bridge. So are you sure that it makes sense to rename panel_port to output_port? Or do you want to rename the panel_bridge member also? /Esben
