Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider: - [Low] Incomplete refactoring causes build failure in the gma500 driver due to unconverted usages of `drm_simple_encoder_init()`. --
--- Patch [15]: [PATCH v2 15/15] Documentation/gpu: remove completed drm_simple_encoder_init() todo --- commit ecefbc42ff1cbd0e228a1785c066cd3cab8deafc Author: Diogo Silva <[email protected]> Documentation/gpu: remove completed drm_simple_encoder_init() todo All drm_simple_encoder_init() users have been removed, so drop the completed todo item. > diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst > index 14cf37590fc7e..b7351467dc74c 100644 > --- a/Documentation/gpu/todo.rst > +++ b/Documentation/gpu/todo.rst > @@ -29,21 +29,6 @@ refactorings already and are an expert in the specific area > Subsystem-wide refactorings > =========================== > > -Open-code drm_simple_encoder_init() > ------------------------------------ > - > -The helper drm_simple_encoder_init() was supposed to simplify encoder > -initialization. Instead it only added an intermediate layer between atomic > -modesetting and the DRM driver. > - > -The task here is to remove drm_simple_encoder_init(). Search for a driver [Severity: Low] Are there still remaining users of drm_simple_encoder_init() in the tree? Looking at the gma500 driver, it appears there are several unconverted calls remaining, such as in drivers/gpu/drm/gma500/cdv_intel_crt.c: cdv_intel_crt_init() { ... ret = drm_simple_encoder_init(dev, encoder, DRM_MODE_ENCODER_DAC); ... } There also seem to be similar calls in cdv_intel_dp.c, cdv_intel_hdmi.c, cdv_intel_lvds.c, oaktrail_hdmi.c, oaktrail_lvds.c, and psb_intel_lvds.c. Will this cause a build failure when compiling with CONFIG_DRM_GMA500 if the underlying function is removed before these are converted? > -that calls drm_simple_encoder_init() and inline the helper. The driver will > -also need its own instance of drm_encoder_funcs. > - > -Contact: Thomas Zimmermann, respective driver maintainer > - > -Level: Easy > - > Replace struct drm_simple_display_pipe with regular atomic helpers > ------------------------------------------------------------------ -- Sashiko AI review ยท https://sashiko.dev/#/patchset/[email protected]?part=15
