Simplify this macro so it is only one macro, rename it to
SPAR_CHANNEL_SERVER_READY, and get rid of the CamelCase parameter name.

Signed-off-by: Benjamin Romer <benjamin.ro...@unisys.com>
---
 drivers/staging/unisys/common-spar/include/channels/channel.h | 5 ++---
 drivers/staging/unisys/virtpci/virtpci.c                      | 2 +-
 2 files changed, 3 insertions(+), 4 deletions(-)

diff --git a/drivers/staging/unisys/common-spar/include/channels/channel.h 
b/drivers/staging/unisys/common-spar/include/channels/channel.h
index dafb14d..c6d04af 100644
--- a/drivers/staging/unisys/common-spar/include/channels/channel.h
+++ b/drivers/staging/unisys/common-spar/include/channels/channel.h
@@ -93,9 +93,8 @@ ULTRA_CHANNELCLI_STRING(u32 v)
        return (const u8 *)("?");
 }
 
-#define ULTRA_CHANNELSRV_IS_READY(x)     ((x) == CHANNELSRV_READY)
-#define ULTRA_CHANNEL_SERVER_READY(pChannel) \
-       (ULTRA_CHANNELSRV_IS_READY(readl(&(pChannel)->srv_state)))
+#define SPAR_CHANNEL_SERVER_READY(ch) \
+       (readl(&(ch)->srv_state) == CHANNELSRV_READY)
 
 #define ULTRA_VALID_CHANNELCLI_TRANSITION(o, n)                                
\
        (((((o) == CHANNELCLI_DETACHED) && ((n) == CHANNELCLI_DISABLED)) || \
diff --git a/drivers/staging/unisys/virtpci/virtpci.c 
b/drivers/staging/unisys/virtpci/virtpci.c
index 2be0447..160ed82 100644
--- a/drivers/staging/unisys/virtpci/virtpci.c
+++ b/drivers/staging/unisys/virtpci/virtpci.c
@@ -177,7 +177,7 @@ int WAIT_FOR_IO_CHANNEL(ULTRA_IO_CHANNEL_PROTOCOL __iomem  
*chanptr)
 
        while (count > 0) {
 
-               if (ULTRA_CHANNEL_SERVER_READY(&chanptr->ChannelHeader))
+               if (SPAR_CHANNEL_SERVER_READY(&chanptr->ChannelHeader))
                        return 1;
                UIS_THREAD_WAIT_SEC(1);
                count--;
-- 
1.9.1

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to