On Tue, Mar 07, 2017 at 08:19:03PM +0300, Dan Carpenter wrote: > On Tue, Mar 07, 2017 at 09:31:16AM +1100, Tobin C. Harding wrote: > @@ -610,12 +610,7 @@ static void ks_sdio_interrupt(struct sdio_func *func) > > if (atomic_read(&priv->psstatus.status) == > > PS_SNOOZE) { > > if (cnt_txqbody(priv)) { > > ks_wlan_hw_wakeup_request(priv); > > - queue_delayed_work > > - (priv->ks_wlan_hw. > > - ks7010sdio_wq, > > - > > &priv->ks_wlan_hw. > > - rw_wq, 1); > > - return; > > + goto intr_out_with_delay; > > > The original code is crap but this isn't really an improvement. We've > just used a goto to split the code up randomly so it's hard to read.
Righto, let's drop this one and I will come back to it when I understand the module enough to remove the ifdef 0 thanks, Tobin. _______________________________________________ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel