Change if condition to handle invalid value first and
avoid nonsense else's path improving readability.

Signed-off-by: Sergio Paracuellos <sergio.paracuel...@gmail.com>
---
 drivers/staging/ks7010/ks_wlan_net.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/staging/ks7010/ks_wlan_net.c 
b/drivers/staging/ks7010/ks_wlan_net.c
index 71fc8c2..68aece7 100644
--- a/drivers/staging/ks7010/ks_wlan_net.c
+++ b/drivers/staging/ks7010/ks_wlan_net.c
@@ -1970,17 +1970,17 @@ static int ks_wlan_set_beacon_lost(struct net_device 
*dev,
        if (priv->sleep_mode == SLP_SLEEP)
                return -EPERM;
        /* for SLEEP MODE */
-       if (*uwrq >= BEACON_LOST_COUNT_MIN && *uwrq <= BEACON_LOST_COUNT_MAX)
-               priv->reg.beacon_lost_count = *uwrq;
-       else
+       if (*uwrq < BEACON_LOST_COUNT_MIN || *uwrq > BEACON_LOST_COUNT_MAX)
                return -EINVAL;
 
+       priv->reg.beacon_lost_count = *uwrq;
+
        if (priv->reg.operation_mode == MODE_INFRASTRUCTURE) {
                priv->need_commit |= SME_MODE_SET;
                return -EINPROGRESS;    /* Call commit handler */
-       } else {
-               return 0;
        }
+
+       return 0;
 }
 
 static int ks_wlan_get_beacon_lost(struct net_device *dev,
-- 
2.7.4

_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to