On 08.07.2010 15:41, Arnd Bergmann wrote:
> On Wednesday 30 June 2010, Stefan Assmann wrote:
>> diff --git a/drivers/net/igbvf/netdev.c b/drivers/net/igbvf/netdev.c
>> index 5e2b2a8..2fb665b 100644
>> --- a/drivers/net/igbvf/netdev.c
>> +++ b/drivers/net/igbvf/netdev.c
>> @@ -2787,7 +2787,7 @@ static int __devinit igbvf_probe(struct pci_dev *pdev,
>>         netif_carrier_off(netdev);
>>         netif_stop_queue(netdev);
>>
>> -       strcpy(netdev->name, "eth%d");
>> +       strcpy(netdev->name, "veth%d");
>>         err = register_netdev(netdev);
>>         if (err)
>>                 goto err_hw_init;
> 
> Note that 'veth' is the name used for a virtual ethernet pair by
> drivers/net/veth.c. If a variant of your patch gets applied, it would
> probably be useful to use a different naming scheme to avoid confusion
> with the veth driver.

Good point!
Greg suggested vfeth, that should be more descriptive and unique.

  Stefan
---
diff --git a/drivers/net/igbvf/netdev.c b/drivers/net/igbvf/netdev.c
index 5e2b2a8..4d02af8 100644
--- a/drivers/net/igbvf/netdev.c
+++ b/drivers/net/igbvf/netdev.c
@@ -2787,7 +2787,7 @@ static int __devinit igbvf_probe(struct pci_dev *pdev,
        netif_carrier_off(netdev);
        netif_stop_queue(netdev);

-       strcpy(netdev->name, "eth%d");
+       strcpy(netdev->name, "vfeth%d");
        err = register_netdev(netdev);
        if (err)
                goto err_hw_init;

------------------------------------------------------------------------------
This SF.net email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit sprint.com/first -- http://p.sf.net/sfu/sprint-com-first
_______________________________________________
E1000-devel mailing list
E1000-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/e1000-devel
To learn more about Intel® Ethernet, visit 
http://communities.intel.com/community/wired

Reply via email to