Hi Torsten,

The change here is in the naming conventions, "srcname" is no longer a
valid method of naming a code block, try "name" instead. e.g.,

#+name: sh-test-noweb
#+begin_src sh
~
#+end_src      

#+begin_src sh :noweb yes 
ls <<sh-test-noweb>>
#+end_src    

Best,

Torsten Anders <torsten.and...@beds.ac.uk> writes:

> Dear Org babel developers,
>
> In the simple test below I would expect that the second cope block
> expands to "ls ~", but seemingly it instead expands to "ls" only. What
> am I missing?
>
> #+srcname: sh-test-noweb
> #+begin_src sh
> ~
> #+end_src      
>
> #+begin_src sh :noweb yes 
> ls <<sh-test-noweb>>
> #+end_src    
>
> Did anything perhaps change in the literate programming interface?
> Apologies if I missed something obvious or if I am victim of some
> stupid typo.
>
> Thanks a lot! 
>
> Best wishes,
> Torsten
>
>

-- 
Eric Schulte
http://cs.unm.edu/~eschulte/

Reply via email to