Anybody can review this?

Even this includes many changes of lines,
this is very simple.
Then I would go for the next patch.

Or reject this and give me a reason.
Thanks.

Daniel Juyung Seo.

On Fri, Dec 10, 2010 at 2:30 AM, Daniel Juyung Seo <seojuyu...@gmail.com> wrote:
> Hello,
>
> I found that there are three big unnecessary 'if' statements in
> els_scroller.c in elementary.
>
> ex)
>
> static void
> _smart_event_mouse_down(...)
> {
>   ...
>   if (_elm_config->thumbscroll_enable)
>     {
>        Many small if statements and this is very LONG.
>     }
>   NOTHING HERE.
> }
>
> I suggest to use 'return' if _elm_config->thumbscroll_enable equals to
> EINA_FALSE.
> This increases readability of code and reduces unnecessarily cascaded
> indentation.
>
> suggestion)
>
> static void
> _smart_event_mouse_down(...)
> {
>   ...
>   if (!_elm_config->thumbscroll_enable) return;
>
>   "many small if statements"
> }
>
> This pattern could be applied to _smart_event_mouse_move and
> _smart_event_mouse_up as well.
> Please give me some comments on this.
> Thanks.
>
> Daniel Juyung Seo.
>

------------------------------------------------------------------------------
Oracle to DB2 Conversion Guide: Learn learn about native support for PL/SQL,
new data types, scalar functions, improved concurrency, built-in packages, 
OCI, SQL*Plus, data movement tools, best practices and more.
http://p.sf.net/sfu/oracle-sfdev2dev 
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to