On Tue, 22 Mar 2011 10:16:03 +0100 Tristan Lelong
<tristan.lel...@blunderer.org> said:

hmm ok. in it goes - but its elm_menu_close(). as such realistically the menu
SHOULD have its own keyboard navigation controls inside (up/down/left/right
arrow, enter/space, backspace/escape etc. etc.) so you don't have to drive it
from the outside.

> 2011/3/22 Carsten Haitzler <ras...@rasterman.com>:
> > On Mon, 14 Mar 2011 17:40:46 +0100 Tristan Lelong
> > <tristan.lel...@blunderer.org> said:
> >
> > cool. ok.
> >
> > patch 01. elm_menu_discard() - why that name? why can't just
> > evas_object_hide() do the job? even if we had this api shouldn't it be more
> > like elm_menu_hide() or elm_menu_close()? as such tho evas_object_hide()
> > should do just nicely... unless your aim is to do some specific animations
> > etc. evas_object_hide() is meant to guarantee a hidden state immediately.
> > you can of course listen for hide events on the menu obj to handle hiding
> > of sub-items and so on.
> 
> In my mind, the discard menu function should do the same thing as a
> click outside the menu bar : hide menu with animations. This is used
> for having similar behaviour with mouse and with keyboard.
> I choosed to use "discard" because with hide the menu without
> triggering any menu_item action.
> If this is not enought to convince you ;-), I can change the name to
> elm_menu_hide, but as you said, this would imply no delay in state
> change.
> 
> >
> > patch 02. actually looks ok except some minor things. do you compile with
> > warnings on? -W -Wall? you really should.. in svn it goes with fixes. i'm
> > feeling nice today :)
> 
> Thx :-)
> 
> >
> >
> >> Hi, here are the corrected patches. I hope I did not forget anything.
> >>
> >>
> >> 2011/3/10 Tristan Lelong <tristan.lel...@blunderer.org>:
> >> > Ok, I correct all these and I'll submit patches again.
> >> > Thx for the feedback.
> >> >
> >> > Le jeudi 10 mars 2011, Carsten Haitzler <ras...@rasterman.com> a écrit :
> >> >> On Wed, 9 Mar 2011 16:24:10 +0100 Tristan Lelong
> >> >> <tristan.lel...@blunderer.org> said:
> >> >>
> >> >> ok. going to have to "reject" here.
> >> >>
> >> >> patch 1:
> >> >> 1. formatting - elm_menu_discard() in Elementary.h.in doesnt align with
> >> >> the rest of the calls next to it (looks ugly)
> >> >> 2. elm_menu_discard() in elm_menu.c is indented using tabs, not spaces.
> >> >> make it align/look like all the code above/below it :)
> >> >>
> >> >> patch 2:
> >> >> 3. elm_menu_item_selected_get() also not aligned in Elementary.h.in
> >> >> 4. elm_menu_selected_item_get() also add a space between * and the
> >> >> function call.
> >> >> 5. more tabs in elm_menu.c indenting as opposed to spaces.
> >> >> 6. ELM_CHECK_WIDTYPE() is changed to remove the NULL return - this
> >> >> creates a bug.
> >> >> 7. ELM_WIDGET_ITEM_WIDTYPE_CHECK_OR_RETURN provides no return value as
> >> >> arg in elm_menu_item_selected_get(), elm_menu_item_prev_get(),
> >> >> elm_menu_item_next_get ()
> >> >> 8. Eina_List * l there and not Eina_List *l.
> >> >> 9. space between eina_list_data_find_list and ()
> >> >> 10. same with eina_list_next() and eina_list_prev()
> >> >>
> >> >> ... :) (don't worry - you'll learn that we are picky about these
> >> >> things) :)
> >> >>
> >> >>> Hello,
> >> >>>
> >> >>> I was using elementary on a target that only has a keyboard, and I add
> >> >>> to do several modification on the elm_menu to handle keyboard
> >> >>> navigation.
> >> >>> - patch 1: discard a menu from C source code
> >> >>> - patch 2: add accessors for menu items and add the ability to handle
> >> >>> selected item from C source code
> >> >>>
> >> >>>
> >> >>>
> >> >>> --
> >> >>> 618FE3EF
> >> >>
> >> >>
> >> >> --
> >> >> ------------- Codito, ergo sum - "I code, therefore I am" --------------
> >> >> The Rasterman (Carsten Haitzler)    ras...@rasterman.com
> >> >>
> >> >>
> >> >
> >> > --
> >> > 618FE3EF
> >> >
> >>
> >>
> >>
> >> --
> >> 618FE3EF
> >
> >
> > --
> > ------------- Codito, ergo sum - "I code, therefore I am" --------------
> > The Rasterman (Carsten Haitzler)    ras...@rasterman.com
> >
> >
> 
> 
> 
> -- 
> 618FE3EF
> 


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    ras...@rasterman.com


------------------------------------------------------------------------------
Enable your software for Intel(R) Active Management Technology to meet the
growing manageability and security demands of your customers. Businesses
are taking advantage of Intel(R) vPro (TM) technology - will your software 
be a part of the solution? Download the Intel(R) Manageability Checker 
today! http://p.sf.net/sfu/intel-dev2devmar
_______________________________________________
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel

Reply via email to