On Wed, Nov 16, 2011 at 11:07 AM, Jake Verbaten <rayn...@gmail.com> wrote:

> It's simply that
>
> var x = someProto beget { ... }
>
> reads nicer then
>
> var x = someProto extends { ... }
>
> I'd prefer to have readability on the non class related operator then the
> class related operator
>

I was actually suggesting extends on the left - so

    var x = extends someProto { ... }

Which reads better than someProto extends { ... }, because that reads as
though {...} is the parent.

- Russ
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to