Couple of nits WRT modules:

- The instantiationRequest interface is defined as having two properties:
 "execute" and "deps".  I believe "deps" should be spelled "dependencies"
to match the naming conventions throughout the rest of the document.
 Besides that, there is no reason that I can see to optimize keystrokes for
that property name.

- The loader for the current realm is specified as a property of the global
object named "System".  This has always bothered me for two reasons:

  1) The word "system" does not describe the object.  It is a loader, not a
"system".

  2) The current loader is an instance of the Loader type.  It is
incongruent to name an instance with a capitalized identifier.  I believe
it would be more appropriate to provide access to the current loader via a
getter on the Loader or Realm constructor.  For example:

    Realm.loader
    Loader.current
    etc...


Thanks - it's looking great!
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to