>
>> Also, write your echo generator this way. You have to duplicate code.
>>
>>
> Ah, of course - thanks for reminding me.
>
>
Given something like:

    function *echo() input { while (true) yield input }

It seems like what we're trying to do is to emulate a contextual keyword
using a weird "outside of the parameter list" parameter.  I suppose one
ideal future-proof way forward would be to reserve an additional word
inside of generators for this potential use in ES7+.

Of course, everyone would have to agree on what that reserved word should
be...
_______________________________________________
es-discuss mailing list
es-discuss@mozilla.org
https://mail.mozilla.org/listinfo/es-discuss

Reply via email to