On Thu, Oct 15, 2015 at 11:12 PM, Isiah Meadows <[email protected]> wrote: > I like the idea, but could the function names be made a little > shorter? I'd like to at least save some characters on it. Example: > `(a, b) => a > b` is 15 characters, where `Math.greaterThan` is 16. > > For comparison, I also have equivalent versions for the colon-preceded > operators > > Here's some naming ideas I have: [snip]
At that point, though, the use of the Math namespace starts getting weird. Equality and Logical aren't mathematical; Bitwise mostly isn't either. (It can sometimes be used to do mathy things, like using shift to mul/div by a power of 2, but that's not its core purpose.) Put them on a new Op namespace object, or into an Op built-in module. Even shorter, and clearer! ~TJ _______________________________________________ es-discuss mailing list [email protected] https://mail.mozilla.org/listinfo/es-discuss

