On 2020-08-10 20:13, Dimitry Sibiryakov wrote:
10.08.2020 18:58, Vlad Khorsun wrote:
To summarize - I withdraw my initial agreement to add CRC32
calculation to function HASH(). The only argument for this is same
name in plain english for different purpose things.
Very good, thanks.
Shouldn't then HASH() to be renamed into CRYPT_HASH() to prevent
further discussions?..
Appears you are right. We should better have separate functions for
lookup & crypto hashes.
HASH(value USING alg) returning integer
and
CRYPT_HASH(value USING alg) returning varbinary
As soon as we want alrgorithm name in variable we can make that form of
HASH() return maximum required integer (up to int128 if we support
something like MurmurHash3) and appropriate form of CRYPT_HASH() return
vabinary of maximum required length.
Firebird-Devel mailing list, web interface at
https://lists.sourceforge.net/lists/listinfo/firebird-devel