This is called hungarian naming. 
(http://en.wikipedia.org/wiki/Hungarian_notation)

It is generally viewed nowadays as bad practice, in the age of type-aware 
browsers and way too many classes to possibly come up with names for.

I still use it here and there, but descriptive variable names will often 
preclude the need to using prefixes to indicate type.

Scott

-----Original Message-----
From:   [EMAIL PROTECTED] on behalf of Stephen Ford
Sent:   Wed 2/1/2006 8:53 PM
To:     flashcoders@chattyfig.figleaf.com
Cc:     
Subject:        [Flashcoders] Naming conventions for AS2.0 ...

 
Does anyone have an opinion, or a preferred method, in regards to
naming conventions for AS2.0 objects ?
 
For example, Macromedia recommends:
 
clip_mc (movie clip)
comm_lc (local connection)
names_array (array)
beep_sound (sound)
field_txt (text field)
etc, etc, etc
 
but what if I wanted to use an generic object or a boolean datatype:
 
listener_???:Object = new Object();
answer_???:Boolean = false;
 
These are just two datatypes Macromedia doesn't list in terms of
suffixes (search for 'About using suffixes to trigger code hints' in the
official Flash help documentation built into Flash).
 
So another technique I have seen is prefixing variables, like:
 
mcClip (movie clip)
lcComm (local connection)
aNames (array)
etc, etc, etc
 
Someone must have a foolproof way to do this, there must be
a technique that covers all possibilities for naming variables ???
 
Thanks,
Stephen.
 
 _______________________________________________
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders



_______________________________________________
Flashcoders mailing list
Flashcoders@chattyfig.figleaf.com
http://chattyfig.figleaf.com/mailman/listinfo/flashcoders

Reply via email to