Peter B. West wrote:
Jeremias Maerki wrote:

Since I've made the checkstyle.cfg file an integral part of our style
guide I have to bring this up before changing:

I'd like to add a line "checkstyle.ignore.braces = yes". This enables
one line ifs like the following:
[..]

if (isEnabled)
    doOneLiner();
else
    return false;

which is easier to read than

if (isEnabled()) doOoneLiner();
else return false;
And what about this:

if (isEnabled())
    doThis();
    doThat();

Yes, I like explicit braces.

Christian


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, email: [EMAIL PROTECTED]

Reply via email to