Oh, of course.  I completely missed that function.

I think all functions should begin with a verb, but "isSet" seems more natural than "isKey" in this situation, since the array is a product of how PHP handles POST data, not inherent in the HTML itself. For example, if you were coming off of only knowing PHP with register_globals, you wouldn't think of variables as being keys in an array. The function name would describe the implementation, not the data itself.

If I can continue to be pedantic for a moment, "noTags" and "noPath" aren't good function names either. They should be "removeTags" and "removePath" or something similar.

-Matt

----- Original Message ----- From: "Chris Shiflett" <[EMAIL PROTECTED]>
To: "Craig Slusher" <[EMAIL PROTECTED]>
Cc: "Zend Framework General" <fw-general@lists.zend.com>
Sent: Monday, October 02, 2006 9:21 AM
Subject: Re: [fw-general] Zend_Filter_Input


I think you're asking how to tell if a key exists. If so, there is a
method called keyExists() that will perform this check for you.

On a related note, I wish this method were named something like isKey()
to better conform to the existing naming convention. I've been hesitant
to enter this as a bug, but perhaps others agree.

(I think the strict naming convention is one of the benefits of using ZF
for this stuff.)

Reply via email to