I don't think this is a good idea, I use a lot your view helper in my
projects and this is my point of view: while is true that the container
helpers are not so useful, I think that the other methods (render,
addJavascript, addOnLoad, captureJavascript, etc) are very important for the
following reasons:

1. You can specify all the configuration for the library in a single place
(library version, use of cdn, additional plugins files, etc)
2. You can conditionally enable inclusion of javascript (and/or css) files
based on the current controller/action and see entire list of the included
file looking only in a single part of your generated code
3. You can specify onLoad code across different places and find all the
onLoad code in a single place in your generated html. The same apply for
addJavascript helper.

I think the library should be maintained for the previous reasons, maybe
removing the other action helpers, otherwise for the same reasons all the
placeholders view helpers should be removed from the library. What do you
think?

In addition to it I'm writing an application resource which will allow to
configure all jquery aspects (version, ui version, use of cdn, and
additional files to load) using the application.ini file. In this way all
you have to do is to write <?=$this->jQuery()?> in your layout file. In my
opinion it would be very useful to avoid code duplication across projects.
-- 
View this message in context: 
http://zend-framework-community.634137.n4.nabble.com/Discontinuing-Maintenance-of-ZendX-JQuery-Suggest-drop-for-2-0-tp3221856p3238818.html
Sent from the Zend Framework mailing list archive at Nabble.com.

Reply via email to