On Jul 4, 2007, Kenneth Zadeck <[EMAIL PROTECTED]> wrote: >>> enum { BEFORE_RELOAD = -1, DURING_RELOAD = 0, AFTER_RELOAD = 1 } >>> reload_status;
>>> #define BEFORE_RELOAD_P() (reload_status < DURING_RELOAD) >>> #define DURING_RELOAD_P() (reload_status == DURING_RELOAD) >>> #define AFTER_RELOAD_P() (reload_status > DURING_RELOAD) > I do not want to make this change myself: It's as mechanical as the change you proposed, except that yours potentially loses information that would enable someone to recover !BEFORE_RELOAD_P() out of the expanded version of no_new_pseudos. Cleanups can come up later. > The purpose of my patch was to get rid of a variable that had not been > directly connected to reload. Which showed we can get rid of yet another variable, simplifying a number of tests, but that, with your earlier patch, have become more difficult to simplify. -- Alexandre Oliva http://www.lsd.ic.unicamp.br/~oliva/ FSF Latin America Board Member http://www.fsfla.org/ Red Hat Compiler Engineer [EMAIL PROTECTED], gcc.gnu.org} Free Software Evangelist [EMAIL PROTECTED], gnu.org}