Excellent. Thanks.
Alexander Mayrhofer wrote:
Miguel,
Thanks for performing the review. Please find my comments inline.
Comments:
1) The document should be a bit more clear on which registry
IANA has to
operate on. In particular, Section 8 does not mention the
"Enumservice
Registrations" registry (which is the proper name).
Suggestion: modify
the first paragraph in Section 8 to read:
This memo requests IANA to add a new "XMPP" Enumervice to the
Enumservice Registrations registry, according to the
definitions in this
document and RFC 3761 [1].
I have changed the first paragraph as you suggested, it now reads:
This memo requests IANA to add a new "XMPP" Enumservice to the
'Enumservice Registrations' registry, according to the definitions in
this document and RFC 3761 [1].
2) I find a bit weird that references 2 (E.164) and 7 (XMPP) are
normative. I think a reader don't need to understand E.164 or XMPP to
implement this specification. As long as the reader
understand ENUM, and
the XMPP URI/IRI, it is sufficient from an implementation
point of view.
So in my opinion these references are informative.
Agreed, moved to informative. The new "References" section now looks
like:
10. References
10.1. Normative References
[1] Faltstrom, P. and M. Mealling, "The E.164 to Uniform Resource
Identifiers (URI) Dynamic Delegation Discovery System (DDDS)
Application (ENUM)", RFC 3761, April 2004.
[2] Bradner, S., "Key words for use in RFCs to Indicate Requirement
Levels", BCP 14, RFC 2119, March 1997.
[3] Berners-Lee, T., Fielding, R., and L. Masinter, "Uniform
Resource Identifier (URI): Generic Syntax", STD 66, RFC 3986,
January 2005.
[4] Duerst, M. and M. Suignard, "Internationalized Resource
Identifiers (IRIs)", RFC 3987, January 2005.
[5] Saint-Andre, P., "Internationalized Resource Identifiers (IRIs)
and Uniform Resource Identifiers (URIs) for the Extensible
Messaging and Presence Protocol (XMPP)", RFC 4622, August 2006.
10.2. Informative References
[6] Mockapetris, P., "Domain names - Implementation and
Specification", STD 13, RFC 1035, November 1987.
[7] ITU-T, "The international public telecommunication numbering
plan", Recommendation E.164 (02/05), Feb 2005.
[8] Yergeau, F., Paoli, J., Sperberg-McQueen, C., Bray, T., and E.
Maler, "Extensible Markup Language (XML) 1.0 (Third Edition)",
W3C REC REC-xml-20040204, February 2004.
[9] Saint-Andre, P., Ed., "Extensible Messaging and Presence
Protocol (XMPP): Core", RFC 3920, October 2004.
Thanks,
Alex
_______________________________________________
Gen-art mailing list
[email protected]
https://www1.ietf.org/mailman/listinfo/gen-art
--
Please note my new e-mail address: miguel.garcia at nsn.com
Miguel A. Garcia tel:+358-50-4804586
Nokia Siemens Networks Helsinki, Finland
_______________________________________________
Gen-art mailing list
[email protected]
https://www1.ietf.org/mailman/listinfo/gen-art