Vlastimil Babka <[EMAIL PROTECTED]> wrote:

> I would prefer something that 
> doesn't add extra lines to ebuild.

I think I would disagree with you here.  I think that having a special
'eblank' or 'eseparator' command is much more readable in an ebuild.
Consider:

pkg_postinst() {
        elog "Knock knock"
        eblank
        ewarn "Who's there?"
        eblank
        elog "Interrupting Cow"
        eblank
        ewarn "Interrup..."
        elog "Moo!"
}

Versus:

pkg_postinst() {
        elog -p "Knock knock"
        ewarn "Who's there?"
        elog -pt "Interrupting Cow"
        ewarn "Interrup..."
        elog "Moo!"
}

I think that in the former case it's much more obvious how the actual
output is going to look.  If the cost is an ebuild that's 3 lines
longer, I think that's reasonable.

-- 
Jim Ramsay
Gentoo/Linux Developer (rox,gkrellm)

Attachment: signature.asc
Description: PGP signature

Reply via email to