On Sat, Sep 6, 2008 at 10:36 AM, Thomas Anderson <[EMAIL PROTECTED]> wrote: > Hi, > Currently we have a lot of: > src_configure() { > econf $(use_enable dvdr) \ > $(use_with ipv6 ssl) \ > --with-system-zlib > } > > Introducing(Idea shamelessly taken from Exherbo): > DEFAULT_SRC_CONFIGURE_USE_{WITHS,ENABLES} > DEFAULT_SRc_CONFIGURE_EXTRA_PARAMS > > The code from above could be rewritten like so: > > DEFAULT_SRC_CONFIGURE_USE_ENABLES=( 'dvdr' ) > DEFAULT_SRC_CONFIGURE_USE_WITHS=( 'ipv6 ssl' ) > DEFAULT_SRC_CONFIGURE_EXTRA_PARAMS=( '--with-system-zlib' ) > > That's much simpler.
It saves you 1 line and reduces readability and intuitiveness by a fair margin; how is it simpler? > > Also taken from Exherbo, DEFAULT_SRC_COMPILE_PARAMS could be used to > append parameters to emake like so: > > src_compile() { > emake buildtarget > } > > which would be replaced by: > DEFAULT_SRC_COMPILE_PARAMS=( 'buildtarget' ) > > This was originally proposed in bug #230725[1] > > Regards, > Thomas > > [1] https://bugs.gentoo.org/show_bug.cgi?id=230725 >