2016-04-22 9:18 GMT+02:00 Andrea Aime <andrea.a...@geo-solutions.it>:

> On Thu, Apr 21, 2016 at 2:27 PM, Mark Prins <mc.pr...@gmail.com> wrote:
>
>> > Where is it documented?
>>
>> Quick search got us this:
>> https://osgeo-org.atlassian.net/browse/GEOT-4883
>> and we googled some more messages on it.
>>
>> This happened over christmas so it's gone a bit hazy by now, we upgraded
>> from 9.x to 14.x during that period, (late yes, but we were tied to
>> supporting Java 6)
>>
>
> Could you share with us a bit more about how the change affected your
> application?
> Your request of keeping support for the old wfs store seems to imply
> switching
> to wfs-ng would be a significant rework of your application
>
>
Sure,

In our application we have an admin define a view/map service (eg. WMS),
while the capabilities are retrieved we also try to discover a WFS (to use
for attribute info, tables, graphs etc.), if not discoverable the admin may
specify one himself (even a different service).

We store the WFS typenames in a table in our backend like so:

id;  description;            geom-attr; type_name;
;writable; source id
"68";"Bedrijventerrein_kavels"; "geom";"Economie:Bedrijventerrein_kavels";
FALSE;14
"70";"EcMo_Wonen_regios";       "geom";"Economie:EcMo_Wonen_regios";
FALSE;14
"79";"BeschikbarePandenOpBedrijventerreinen";"geom";"IBIS_BeschikbarePandenOpBedrijventerreinen";FALSE;16
"80";"";                        "geom";"bedrijvenkavels_tijdelijk";
 TRUE;11


"Economie:Bedrijventerrein_kavels" being the typename reported by the WFS,
a test case illustrating this [0]. We use this typename to request features
from the WFS [1],

If I recall correctly wfs-ng reports "Economie_EcMo_Wonen_regios" as a
typename (instead of "Economie:EcMo_Wonen_regios") which breaks when just
using that in a getfeatures request also because the underscore is a
legitimate character in both layer name and namespace name (contrary to the
colon) it becomes impossible to determine which part is which (not possible
to use a simple split on ':' anymore). Our stored type_name is used in
various places in our application.

We can/should probably expand our model to store typename and namespace
separately to use this new naming convention and update the code to use
that. And cook up a migration script for our users.


[0]
https://github.com/flamingo-geocms/flamingo/blob/master/viewer-admin/src/test/java/nl/b3p/viewer/admin/stripes/WFSTypeNamingTest.java#L199
[1] eg.
https://github.com/flamingo-geocms/flamingo/blob/master/viewer-config-persistence/src/main/java/nl/b3p/viewer/config/services/WFSFeatureSource.java#L246



-- 
Disclaimer;
This message is just a reflection of what I thought at the time of sending.
The message may contain information that is not intended for you or that
you don't understand.
------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
GeoTools-Devel mailing list
GeoTools-Devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geotools-devel

Reply via email to