laforge has submitted this change. ( https://gerrit.osmocom.org/c/osmo-mgw/+/31636 )
Change subject: mgcp_e1: rename e1_send to e1_send_ts_frame ...................................................................... mgcp_e1: rename e1_send to e1_send_ts_frame The function name e1_send is very generic, lets make clear that one E1 timeslot frame is sent. Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef --- M src/libosmo-mgcp/mgcp_e1.c 1 file changed, 14 insertions(+), 2 deletions(-) Approvals: laforge: Looks good to me, approved pespin: Looks good to me, but someone else must approve Jenkins Builder: Verified diff --git a/src/libosmo-mgcp/mgcp_e1.c b/src/libosmo-mgcp/mgcp_e1.c index 80a48ab..6d1f891 100644 --- a/src/libosmo-mgcp/mgcp_e1.c +++ b/src/libosmo-mgcp/mgcp_e1.c @@ -310,7 +310,7 @@ } /* handle outgoing E1 traffic */ -static void e1_send(struct e1inp_ts *ts, struct mgcp_trunk *trunk) +static void e1_send_ts_frame(struct e1inp_ts *ts, struct mgcp_trunk *trunk) { struct msgb *msg = msgb_alloc_c(trunk, E1_TS_BYTES, "E1-TX-timeslot-bytes"); uint8_t *ptr; @@ -359,7 +359,7 @@ osmo_i460_demux_in(&trunk->e1.i460_ts[ts->num - 1], msgb_data(msg), msgb_length(msg)); /* Trigger sending of pending E1 traffic */ - e1_send(ts, trunk); + e1_send_ts_frame(ts, trunk); /* e1inp_rx_ts() does not free() msgb */ msgb_free(msg); -- To view, visit https://gerrit.osmocom.org/c/osmo-mgw/+/31636 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: osmo-mgw Gerrit-Branch: master Gerrit-Change-Id: I5fba7993860a63149a13d943edbfabc4008680ef Gerrit-Change-Number: 31636 Gerrit-PatchSet: 2 Gerrit-Owner: dexter <pma...@sysmocom.de> Gerrit-Reviewer: Jenkins Builder Gerrit-Reviewer: laforge <lafo...@osmocom.org> Gerrit-Reviewer: pespin <pes...@sysmocom.de> Gerrit-MessageType: merged