On Wed, Jun 24, 2009 at 5:08 PM, Ray Cromwell<cromwell...@gmail.com> wrote:
> I prefer 4 as well, because I think it will be less prone to error and it is
> more directly associated with the runAsync call.
> However, I'm curious, what is the effect of the following:
> GWT.runAsync("foo", callback1);
> GWT.runAsync("bar", callback1);
> That would appear to me to generate identical code, but with two different
> named output files.

Ideally, the compiler would figure out that they are the same and do
something smart.  Right now, though, the results would tend to be bad.


> On the other hand, what about this:
> GWT.runAsync("foo", callback1);
> GWT.runAsync("foo", callback2);
> here, two different callbacks try to use the same name.

This is a subtopic common to any naming scheme:  What happens if the
same name is specified for two calls?  It either needs to be a compile
error, or a warning.  Either way, the name is not allowed to be used.

Lex

--~--~---------~--~----~------------~-------~--~----~
http://groups.google.com/group/Google-Web-Toolkit-Contributors
-~----------~----~----~----~------~----~------~--~---

Reply via email to