https://bugs.gpodder.org/show_bug.cgi?id=774

--- Comment #9 from Tim Abell <[email protected]> 2010-03-15 23:26:37 GMT ---
(In reply to comment #7)

>  * The "Limit count" in the UI should be a spinner box (integers starting at 
> 1)

got stuck with this, apparently my gtk-python skillz aren't up to it yet, any
help would be appreciated.


>  * The "no limit" should be 0 (zero), not None (to avoid converting issues)

done


>  * keepLimit should be renamed to "keep_limit" (no camelCase for attributes)

done


>  * You don't have to update "finger_friendly_widgets" in
>    src/gpodder/gtkui/desktop/episodeselector.py

removed


>  * You have to write code for both "maemo" and "frmntl" in episodeselector.py
>    (so that Maemo 4 and Maemo 5 UIs also gain this feature)

Not sure how to go about this, I tried running with the other interfaces
switched on but I get
bin/gpodder -f   ...   ImportError: No module named hildon
as you might expect.
Any help would be appreciated.


>  * Again, no camelCase ("runningCleanup")

done


>  * "if hasattr(self, 'runningCleanup') and self.runningCleanup:" can be better
>    written as: "if getattr(self, 'running_cleanup', False):"

done


>  * The "Select by limit" button could have a better name (I don't have
>    a suggestion for a better name, though...)
> 

I thought the same. I'm open to suggestions.

Is it critical that maemo gets the extra feature before you'll include the
patch in the program?

Thanks for the feedback.

-- 
Configure bugmail: https://bugs.gpodder.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
_______________________________________________
gPodder-Bugs mailing list
[email protected]
https://lists.berlios.de/mailman/listinfo/gpodder-bugs

Reply via email to