Hi,

I would like to propose the following patch:
+++
[EMAIL PROTECTED]:~/harmony/enhanced/trunk/sandbox/contribs/bootjvm/bootJVM> svn diff jvm/src/opcode.c
Index: jvm/src/opcode.c
===================================================================
--- jvm/src/opcode.c    (revision 329310)
+++ jvm/src/opcode.c    (working copy)
@@ -985,7 +985,7 @@
 * creating better readability of the code.
 */

-static void dummy1(void) { char *p, *dummy2; dummy2 = p; dummy1(); }
+static void dummy1(void) { void (*p)()=NULL; p(); }
#define STUB { dummy1(); }

switch(opcode)
+++
The idea is to core ASAP when we reach a not yet supported opcode, any comment?

Cheers

Jean-Frederic

Reply via email to