[ 
https://issues.apache.org/jira/browse/HDFS-462?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jakob Homan reassigned HDFS-462:
--------------------------------

    Assignee: Jakob Homan

> Unit tests not working under Windows
> ------------------------------------
>
>                 Key: HDFS-462
>                 URL: https://issues.apache.org/jira/browse/HDFS-462
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: name-node, test
>    Affects Versions: 0.21.0
>         Environment: Windows
>            Reporter: Luca Telloli
>            Assignee: Jakob Homan
>             Fix For: 0.21.0
>
>
> Unit tests are failing on windows due to a problem with rename. 
> The failing code is around line 520 in FSImage.java: 
> {noformat}
>       assert curDir.exists() : "Current directory must exist.";
>       assert !prevDir.exists() : "prvious directory must not exist.";
>       assert !tmpDir.exists() : "prvious.tmp directory must not exist.";
>       // rename current to tmp
>       rename(curDir, tmpDir);
>       // save new image
>       if (!curDir.mkdir())
>         throw new IOException("Cannot create directory " + curDir);
> {noformat}
> and seems related to some open file or directory

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to