[ 
https://issues.apache.org/jira/browse/HDFS-11775?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16013062#comment-16013062
 ] 

Xiaoyu Yao commented on HDFS-11775:
-----------------------------------

Thanks @Nandakuma for working on this. The patch looks good to me overall. Here 
are a few comments:

BucketManager.java
Since most of existing KSM/SCM don't have a separate interface in the package 
name,
let's keep them together for consistency.

Line 26: need javac doc for the public methods.

DistributedStorageHandler.java

Line 71: unused import
import static org.apache.hadoop.scm.storage.ContainerProtocolCalls.putKey;

KsmBucketArgs.java
Line 102/110: extra space between public and List

KeySpaceManagerProtocol.proto
Line 161/176: Can we rename this to isVersionEnabled and use simple boolean 
instead?
If yes, we should make this optional with default=false. 

Line 166: we should use the StorageTypeProto defined in hdfs.proto instead of 
define a new one StorageType.

Line 181: NIT: suggest rename OzoneACLType to OzoneAclType for consistency.
Line 186: NIT: suggest rename OzoneACLRights to OzoneAclRights for consistency.

KSMException.java/OzoneAcl.java
We might need some Acl related error codes later. It is OK for now since the 
AclCheck
is not implemented yet in OzoneAcl.java. Please open a separate ticket if we 
don't have one for that yet.

TestBucketManagerImpl.java
Line 122: you can use thrown.expectMessage to validate the expected exception.

> Ozone: KSM : add createBucket 
> ------------------------------
>
>                 Key: HDFS-11775
>                 URL: https://issues.apache.org/jira/browse/HDFS-11775
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>    Affects Versions: HDFS-7240
>            Reporter: Anu Engineer
>            Assignee: Nandakumar
>         Attachments: HDFS-11775-HDFS-7240.000.patch, 
> HDFS-11775-HDFS-7240.001.patch
>
>
> Creates a bucket if it does not exist. A precondition to creating a bucket is 
> that a parent volume must exist.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to