[ 
https://issues.apache.org/jira/browse/HDFS-11898?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16032260#comment-16032260
 ] 

Konstantin Shvachko commented on HDFS-11898:
--------------------------------------------

The concept of {{HEDGED_READ_THREAD_POOL}} looks broken to me.
* I think we should not have it static and name it up to naming conventions: 
{{hedgedReadThreadPool}}.
* DFSClients are cached so this will be a common pool per URI. Keeping it 
common for all URIs is not right.
* Also I think we should reset {{hedgedReadThreadPool}} in 
{{initThreadsNumForHedgedReads()}} when the number of threads is {{num <= 0}}. 
Now we reset the pool if {{num > 0}}, why 0 should be different.
* This should solve HDFS-11900 as well.

> DFSClient#isHedgedReadsEnabled() should be per client flag 
> -----------------------------------------------------------
>
>                 Key: HDFS-11898
>                 URL: https://issues.apache.org/jira/browse/HDFS-11898
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: hdfs-client
>            Reporter: Vinayakumar B
>            Assignee: Vinayakumar B
>         Attachments: HDFS-11898-01.patch
>
>
> DFSClient#isHedgedReadsEnabled() returns value based on static 
> {{HEDGED_READ_THREAD_POOL}}. 
> Hence if any of the client initialized this in JVM, all remaining client 
> reads will be going through hedged read itself.
> This flag should be per client value.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to