[ 
https://issues.apache.org/jira/browse/HDFS-15535?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17180759#comment-17180759
 ] 

Íñigo Goiri commented on HDFS-15535:
------------------------------------

Yes, makes sense to cast both, either one is fine with me.
I guess he most consistent one is to do the cast outside for both.
{code}
@SuppressWarnings("unchecked")
T loc = (T)location;
@SuppressWarnings("unchecked")
R ret = (R) result;
return new RemoteResult<>(loc, ret);
{code}

I'm fine either way.

> RBF: Fix Namespace path to snapshot path resolution for snapshot API
> --------------------------------------------------------------------
>
>                 Key: HDFS-15535
>                 URL: https://issues.apache.org/jira/browse/HDFS-15535
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Ayush Saxena
>            Assignee: Ayush Saxena
>            Priority: Major
>         Attachments: HDFS-15535-01.patch, HDFS-15535-02.patch, 
> HDFS-15535-03.patch, HDFS-15535-04.patch, HDFS-15535-05.patch, 
> HDFS-15535-06.patch
>
>
> Presently, after invoking {{createSnapshot}} and {{getSnapshotListing}}, the 
> namespace path is replaced with mount path.
>  This presumes as of now that, the invokedLocation shall always be the first 
> one in the sequence, but there are multiple reasons, where the directory 
> might not be in the first location.
>  So, rather than replacing using firstLocation, we should replace path using 
> actual invoked Location.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to