[ 
https://issues.apache.org/jira/browse/HDFS-5647?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13844761#comment-13844761
 ] 

Jing Zhao commented on HDFS-5647:
---------------------------------

The patch looks good to me. Some minors:
# We can remove the following check:
{code}
+  protected void removeFeature(Feature f) {
+    Preconditions.checkNotNull(features, "Feature"
+        + f.getClass().getSimpleName() + " not found.");
{code}
# The equals should be "==" for the current implementation:
{code}
+    for (Feature f1 : features) {
+      if (f.equals(f1)) {
+        continue;
+      }
{code}

> Merge INodeDirectory.Feature and INodeFile.Feature
> --------------------------------------------------
>
>                 Key: HDFS-5647
>                 URL: https://issues.apache.org/jira/browse/HDFS-5647
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>         Attachments: HDFS-5647.000.patch
>
>
> HDFS-4685 implements ACLs for HDFS, which can benefit from the INode features 
> introduced in HDFS-5284. The current code separates the INode feature of 
> INodeFile and INodeDirectory into two different class hierarchies. This 
> hinders the implementation of ACL since ACL is a concept that applies to both 
> INodeFile and INodeDirectory.
> This jira proposes to merge the two class hierarchies (i.e., 
> INodeDirectory.Feature and INodeFile.Feature) to simplify the implementation 
> of ACLs.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Reply via email to