Bob Silva wrote:
> It should be a function and not a language construct IMHO. Either ifsetor or
> overload the isset statement (which may not be possible within the engine).

It _has_ to be a language construct, and not a function (otherwise, we'd
 get a notice when first using the variable).

It could, however, be a language construct that LOOKS like a function.
This is how isset() and empty() work.

Also, if this was possible as a function, it could be solved in
user-space, and we wouldn't be having this conversation.

(not that I claim to be an internals expert.. if I'm wrong, feel free to
correct me)

To pitch in my 0.02 CAD: this functionality is valuable to me, but I
don't care what we name it, or how it works. I could also live without
it: isset() + ternary + redundant typing.

S

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to