On 20/02/2008, Stefan Marr <[EMAIL PROTECTED]> wrote:
> > If we feel it gets necessary we probbaly
>  > might want to support a syntax like:
>  >  'trait_method' => false
>  >  'trait_method' => 'new_name'
>  >  'trait_method' => array('new_name', 'trait_method'
>
> I'm not comfortable with this notation, since it strengthens the
>  impression that it is renaming.
>
>  In my eyes it looks like this:
>
>  "trait_method => false" means trait_method is moved to false, it is
>  deleted, but this leads to the wrong impression of this:
>  "trait_method => new_name" means trait_method is moved to new_name,
>  and I am absolutely against this notion.
>
>  Kind Regards
>  Stefan

What would you all read this to be ...

void := 'trait_method'
'new_name' := 'trait_method'
array('new_name', 'trait_method') := 'trait_method'

:= is "becomes equal".





-- 
-----
Richard Quadling
Zend Certified Engineer : http://zend.com/zce.php?c=ZEND002498&r=213474731
"Standing on the shoulders of some very clever giants!"

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to