However, extension headers defined since 2460 have to be added. That's the case for MIPv6, SHIM6 and HIP.
This matters - there are known to be boxes that discard packets with a SHIM6 header, for example. We do maybe need a little normative RFC on this. Regards Brian Carpenter On 2012-05-22 16:33, Duncan, Jeremy wrote: > yes, sect 4 of RFC 2460: > > A full implementation of IPv6 includes implementation of the > following extension headers: > > Hop-by-Hop Options > Routing (Type 0) > Fragment > Destination Options > Authentication > Encapsulating Security Payload > > The first four are specified in this document; the last two are > specified in [RFC-2402] and [RFC-2406], respectively. > > 4.1 Extension Header Order > > When more than one extension header is used in the same packet, it is > recommended that those headers appear in the following order: > > IPv6 header > Hop-by-Hop Options header > Destination Options header (note 1) > Routing header > Fragment header > > > http://www.ietf.org/rfc/rfc2460.txt > > > 010100110110010101101101011100000110010101110010001000000100011001101001 > > Jeremy Duncan > Senior Director, IPv6 Network Architect Salient Federal Solutions, Inc. > (Now including SGIS & Command Information Inc.) > 4000 Legato Road, Suite 600 Fairfax, VA 22033 > Google Voice: 540.440.1193 > [email protected] > ________________________________ > From: [email protected] [[email protected]] on behalf of Marksteiner, > Stefan [[email protected]] > Sent: Tuesday, May 22, 2012 11:04 AM > To: '[email protected]' > Subject: Is there an official Extension Headers List? > > Hello, > > I just wonder if any *official* summarization of currently existing IPv6 > extension headers exists. > The only way I found to determine all headers is to step through the IANA > protocol numbers list and check in the references whether the according > protocol has a defined IPv6 extension header. > As far as I see it a complete current list would be: > Hop-by-Hop Option 0 > Routing Header 43 > Fragment Header 44 > AH 51 > ESP 50 > Destination Options 60 > Mobility Header 135 > Host Identity Protocol 139 > Shim6 Protocol 140 > > Is there something I missed or misinterpreted? Or is there actually an > official list (a citable source would fit my needs best)? > Thanks in advance. > > Cheers, > > Stefan > > > > ------------------------------------------------------------------------ > > -------------------------------------------------------------------- > IETF IPv6 working group mailing list > [email protected] > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6 > -------------------------------------------------------------------- -------------------------------------------------------------------- IETF IPv6 working group mailing list [email protected] Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6 --------------------------------------------------------------------
