[ 
https://issues.apache.org/jira/browse/CALCITE-2970?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17098245#comment-17098245
 ] 

Xiening Dai commented on CALCITE-2970:
--------------------------------------

hi [~zabetak], if I understand correctly, if we want to use 
RelBuilder#transform, we would be doing something like this -
{code:java}
RelBuilder enumerableBuilder = call.builder().transform(c -> 
c.withRelFactoriesStruct(enumeralbeRelFactoriesStruct));
{code}
This piece of code would have to appear every time when we want to get a 
builder for enumerables. Compared with the current proposal -
{code:java}
RelBuilder enumerableBuilder = 
enumerableConvention.transformRelBuilder(builder);
{code}
I feel it's worse in terms of code readability and maintainability.

> Performance issue when enabling abstract converter for EnumerableConvention
> ---------------------------------------------------------------------------
>
>                 Key: CALCITE-2970
>                 URL: https://issues.apache.org/jira/browse/CALCITE-2970
>             Project: Calcite
>          Issue Type: Bug
>          Components: core
>            Reporter: Haisheng Yuan
>            Priority: Major
>              Labels: pull-request-available
>          Time Spent: 18h 20m
>  Remaining Estimate: 0h
>
> If we enable the use of abstract converter for {{EnumerableConvention}}, by 
> making {{useAbstractConvertersForConversion}} return true, 
> {{JDBCTest.testJoinManyWay}} will not complete.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to