[ 
https://issues.apache.org/jira/browse/CAMEL-7492?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14028376#comment-14028376
 ] 

Christian Müller commented on CAMEL-7492:
-----------------------------------------

Why not simply:
{code}
<xpath>/foo/bar</xpath>
{code}
or
{code}
<choice>
  <when><xpath>/foo/bar</xpath>
    <to uri="jms:fooOrBar"/>
  </when>
...
{code}
?

I think it's because of the backwards compatibility, but is there a real use 
case where the user would like to receive the exception instead of true/false?

May be we should introduce the change in the behavior (being not backwards 
compatible) but providing a better default behavior.

> xpath/xquery - Allow to suppress exceptions when used as predicate
> ------------------------------------------------------------------
>
>                 Key: CAMEL-7492
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7492
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-core, camel-saxon
>            Reporter: Claus Ibsen
>            Priority: Minor
>             Fix For: Future
>
>
> See
> http://stackoverflow.com/questions/24124015/apache-camel-xpath-routing
> If you use a content based router, and have different kind of xml coming in, 
> you may want to ignore any exceptions, if a < xpath > expression fails to 
> evaluate as the xml does not fit that format.
> So if we have
> {code}
>    <xpath ignoreException="true">/foo/bar</xpath>
> {code}
> eg a new attribute to set a flag to ignore exceptions. Though naming is hard, 
> so maybe there is a better name for the attribute.
> Related is also the validate eip, but I dont think we can use that as an 
> expression/predicate: http://camel.apache.org/validate
> Otherwise we could do something like this; which may be even better as then 
> it works with any Camel expression/predicate. 
> {code:xml}
> <choice>
>    <when><validate><xpath>/foo/bar</xpath></validate>
>      <to uri="jms:fooOrBar"/>
>   </when>
>   ...
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to