KuiLIU created CLOUDSTACK-10364:
-----------------------------------

             Summary: Inconsiste "setXXX" method names.
                 Key: CLOUDSTACK-10364
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10364
             Project: CloudStack
          Issue Type: Improvement
      Security Level: Public (Anyone can view this level - this is the default.)
            Reporter: KuiLIU


The following two methods are named as "setXXX",
actually, they are not setter but getter.
Thus, they should be renamed as "getXXX".
{code:java}
 private String setVnetBrName(String pifName, String vnetId) {
        return "br" + pifName + "-" + vnetId;
    }

    private String setVxnetBrName(String pifName, String vnetId) {
        return "brvx-" + vnetId;
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to