[ 
https://issues.apache.org/jira/browse/HBASE-1517?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12886129#action_12886129
 ] 

ryan rawson commented on HBASE-1517:
------------------------------------

it would be really nice if Java let us have 'optional methods' that didnt 
require adding to all implementors.  I think with a good refactoring IDE it 
should be able to auto-add all the implementations for you.  Lets go with the 
new method, it just looks cleaner in existing code, and will reduce errors by 
readers.  Tend towards readability, since code gets read more than written.

So StoreScanner.reseek() exists to reset the scanner stack during certain 
regionserver events (flushes, compactions) when we have to re-read the store 
files, and then re-seek the scanner stack.  It should probably be renamed in 
the face of this new feature, perhaps to 'resetScannerStack' or something like 
that.



> Implement inexpensive seek operations in HFile
> ----------------------------------------------
>
>                 Key: HBASE-1517
>                 URL: https://issues.apache.org/jira/browse/HBASE-1517
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 0.20.0
>            Reporter: Jonathan Gray
>            Assignee: ryan rawson
>             Fix For: 0.21.0
>
>
> When we early-out of a row because of columns, versions, filters, etc... we 
> seek to the end of that row one key at a time.  We should do the seek at the 
> HFile level in cases where we would end up skipping blocks in the process.  
> This will be very common in cases with relatively large rows and regex row 
> filters.
> If calls that end up doing nothing are constant time, we could also call this 
> to seek to the next column (or even a specific column in ExplicitTracker 
> case).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to