[ 
https://issues.apache.org/jira/browse/HBASE-10801?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13975062#comment-13975062
 ] 

stack commented on HBASE-10801:
-------------------------------

We use ByteBuffer instead of ByteRange?  Thats ok?

What is going on here in extractOffsetsAndLengthsFromKey?  We have a byte 
buffer and we are doing the interpretation of this buffer as a KeyValue and 
saving the values into a SeekerStateMembers?  What happens when the encoding is 
not KeyValue?  Why SeekerStateMembers at all and not just create a KeyValue 
over this buffer (Then the interpreting code stays inside KeyValue and doesn't 
leak out here)?  Maybe that is not possible?

Should these be throwing UnsupportedOperationException instead of a null when 
we do these?

+      // TODO Auto-generated method stub
+      return null;

So, this is that trick of yours where you just copy the key again?

+  protected static class KeyOnlyClonedSeekerState implements Cell {

It needs explaining in class comment.

Why even take the value as arguments if we are not going to make use of it?

+    private int valueOffset;
+    private int valueLength;

And then we have special flags external to the Cell for if tags are compressed 
or not?

+      if(tagCompressionContext != null) {

(The external compressed tags flag comes from hfile?)

Is SeekerStateMembers a good name?  Would SeekerStateCoordinates or 
SeekerStateLocation be a better name?

How you interpret the perf numbers?  That this stuff doesn't make things worse 
-- that after warm up, we are doing maybe a bit better w/ the new code?

Good on you Ram.








> Ensure DBE interfaces can work with Cell
> ----------------------------------------
>
>                 Key: HBASE-10801
>                 URL: https://issues.apache.org/jira/browse/HBASE-10801
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: ramkrishna.s.vasudevan
>            Assignee: ramkrishna.s.vasudevan
>             Fix For: 0.99.0
>
>         Attachments: HBASE-10801.patch, HBASE-10801_1.patch, 
> HBASE-10801_2.patch, HBASE-10801_3.patch, HBASE-10801_4.patch
>
>
> Some changes to the interfaces may be needed for DBEs or may be the way it 
> works currently may be need to be modified inorder to make DBEs work with 
> Cells. Suggestions and ideas welcome.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to