[ 
https://issues.apache.org/jira/browse/HBASE-4199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13084856#comment-13084856
 ] 

Ted Yu commented on HBASE-4199:
-------------------------------

It would be easier for other developers to make review comments if review board 
was used.
{code}
+/**
+ * This class provides tests for the {@link HTableUtil} class
+ *
+ */
+public class TestBlockCacheSummary {
{code}
Please update javadoc with brief description of what is tested in the above 
class.
{code}
+  /**
+   * 
+   */
+  public BlockCacheSummaryEntry() {
+    
+  }
{code}
The above can be made package private. Please also fill in javadoc.
Earlier in the same class:
{code}
+  private String table;
+  private String columnFamily;
{code}
Would it be more general if the above two fields were declared as byte[] ?
{code}
+   * @return heapSize
+   */
+  public int getBlocks() {
+    return blocks;
{code}
Please correct javadoc.


> blockCache summary - backend
> ----------------------------
>
>                 Key: HBASE-4199
>                 URL: https://issues.apache.org/jira/browse/HBASE-4199
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Doug Meil
>            Assignee: Doug Meil
>            Priority: Minor
>         Attachments: java_HBASE_4199.patch
>
>
> This is the backend work for the blockCache summary.  Change to BlockCache 
> interface, Summarization in LruBlockCache, BlockCacheSummaryEntry, addition 
> to HRegionInterface, and HRegionServer.
> This will NOT include any of the web UI or anything else like that.  That is 
> for another sub-task.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to